[libdvdcss-devel] [PATCH 5/9] Fix calculation of cache filename length.
Diego Biurrun
diego at biurrun.de
Tue Nov 4 15:15:07 CET 2014
The calculation skipped some parts that are included in the filename.
---
src/libdvdcss.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/libdvdcss.c b/src/libdvdcss.c
index 2fb09e2..65a6267 100644
--- a/src/libdvdcss.c
+++ b/src/libdvdcss.c
@@ -270,7 +270,8 @@ static char *set_cache_directory( dvdcss_t dvdcss )
/* Check that there is enough space for the cache directory path and the
* block filename. The +1 are path separators and terminating null byte. */
else if( strlen( psz_cache ) + 1 + DISC_TITLE_LENGTH + 1 +
- STRING_KEY_SIZE + CACHE_FILENAME_LENGTH + 1 > PATH_MAX )
+ MANUFACTURING_DATE_LENGTH + 1 + STRING_KEY_SIZE + 1 +
+ CACHE_FILENAME_LENGTH + 1 > PATH_MAX )
{
print_error( dvdcss, "cache directory name is too long" );
return NULL;
--
1.9.1
More information about the libdvdcss-devel
mailing list