[libdvdcss-devel] [PATCH 16/47] ioctl: Replace magic number by DVDCSS_BLOCK_SIZE macro
Diego Biurrun
diego at biurrun.de
Wed Oct 29 21:33:16 CET 2014
---
src/ioctl.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/ioctl.c b/src/ioctl.c
index c33ea66..442f91b 100644
--- a/src/ioctl.c
+++ b/src/ioctl.c
@@ -83,8 +83,8 @@
# include <sys/dcmd_cam.h>
#endif
+#include "dvdcss/dvdcss.h"
#include "common.h"
-
#include "ioctl.h"
/*****************************************************************************
@@ -454,7 +454,7 @@ int ioctl_ReadTitleKey( int i_fd, int *pi_agid, int i_pos, uint8_t *p_key )
key->KeyType = DvdTitleKey;
key->KeyFlags = 0;
key->Parameters.TitleOffset.QuadPart = (LONGLONG) i_pos *
- 2048 /*DVDCSS_BLOCK_SIZE*/;
+ DVDCSS_BLOCK_SIZE;
i_ret = DeviceIoControl( (HANDLE) i_fd, IOCTL_DVD_READ_KEY, key,
key->KeyLength, key, key->KeyLength, &tmp, NULL ) ? 0 : -1;
--
1.9.1
More information about the libdvdcss-devel
mailing list