[libdvdcss-devel] ioctl: Replace magic number by DVDCSS_BLOCK_SIZE macro

Diego Biurrun git at videolan.org
Thu Oct 30 17:16:31 CET 2014


libdvdcss | branch: master | Diego Biurrun <diego at biurrun.de> | Fri Oct 24 11:02:39 2014 +0200| [87da5eba2a088334ad08059d30b2502c28cd9f19] | committer: Diego Biurrun

ioctl: Replace magic number by DVDCSS_BLOCK_SIZE macro

> http://git.videolan.org/gitweb.cgi/libdvdcss.git/?a=commit;h=87da5eba2a088334ad08059d30b2502c28cd9f19
---

 src/ioctl.c |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/ioctl.c b/src/ioctl.c
index e60ed3d..063e1c4 100644
--- a/src/ioctl.c
+++ b/src/ioctl.c
@@ -83,8 +83,8 @@
 #   include <sys/dcmd_cam.h>
 #endif
 
+#include "dvdcss/dvdcss.h"
 #include "common.h"
-
 #include "ioctl.h"
 
 /*****************************************************************************
@@ -491,7 +491,7 @@ int ioctl_ReadTitleKey( int i_fd, int *pi_agid, int i_pos, uint8_t *p_key )
         key->KeyType    = DvdTitleKey;
         key->KeyFlags   = 0;
         key->Parameters.TitleOffset.QuadPart = (LONGLONG) i_pos *
-                                                   2048 /*DVDCSS_BLOCK_SIZE*/;
+                                               DVDCSS_BLOCK_SIZE;
 
         i_ret = DeviceIoControl( (HANDLE) i_fd, IOCTL_DVD_READ_KEY, key,
                 key->KeyLength, key, key->KeyLength, &tmp, NULL ) ? 0 : -1;



More information about the libdvdcss-devel mailing list