[vlc-commits] commit: qt4: improve code readability. ( Rémi Duraffort )
git at videolan.org
git at videolan.org
Wed Aug 4 00:29:38 CEST 2010
vlc | branch: master | Rémi Duraffort <ivoire at videolan.org> | Wed Aug 4 00:29:17 2010 +0200| [daae8e520f9441631aed70863198bb2a44107d35] | committer: Rémi Duraffort
qt4: improve code readability.
> http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=daae8e520f9441631aed70863198bb2a44107d35
---
modules/gui/qt4/main_interface.hpp | 14 ++++++++++----
1 files changed, 10 insertions(+), 4 deletions(-)
diff --git a/modules/gui/qt4/main_interface.hpp b/modules/gui/qt4/main_interface.hpp
index e2a5985..d6a5951 100644
--- a/modules/gui/qt4/main_interface.hpp
+++ b/modules/gui/qt4/main_interface.hpp
@@ -214,13 +214,19 @@ private slots:
void showBuffering( float );
- void resizeStack( int w, int h ) {
+ void resizeStack( int w, int h )
+ {
if( !isFullScreen() && !isMaximized() )
- if( b_minimalView ) resize( w, h ); /* Oh yes, it shouldn't
+ {
+ if( b_minimalView )
+ resize( w, h ); /* Oh yes, it shouldn't
be possible that size() - stackCentralW->size() < 0
since stackCentralW is contained in the QMW... */
- else resize( size() - stackCentralW->size() + QSize( w, h ) );
- debug(); }
+ else
+ resize( size() - stackCentralW->size() + QSize( w, h ) );
+ }
+ debug();
+ }
void setVideoSize( unsigned int, unsigned int );
void setVideoFullScreen( bool );
More information about the vlc-commits
mailing list