[vlc-commits] mkv: replaced usage of std::vector with std::map (matroska_segment_c:: tracks)
Filip Roséen
git at videolan.org
Mon May 9 15:09:26 CEST 2016
vlc | branch: master | Filip Roséen <filip at videolabs.io> | Mon May 9 14:53:04 2016 +0200| [46d18e6bb02d67a1dbf7dd8d0bce5f09a17583cf] | committer: Jean-Baptiste Kempf
mkv: replaced usage of std::vector with std::map (matroska_segment_c::tracks)
Managing the tracks by a std::vector has been replaced with a std::map
mapping the track-number to a mkv_track_t.
This patch includes changing BlockFindTrackIndex to FindTrackByBlock,
keeping the same behaviour though using a more accurate name for the new
code.
Signed-off-by: Jean-Baptiste Kempf <jb at videolan.org>
> http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=46d18e6bb02d67a1dbf7dd8d0bce5f09a17583cf
---
modules/demux/mkv/matroska_segment.cpp | 145 +++++++++++++-------------
modules/demux/mkv/matroska_segment.hpp | 6 +-
modules/demux/mkv/matroska_segment_parse.cpp | 104 +++++++++++-------
modules/demux/mkv/mkv.cpp | 140 +++++++++++++++----------
modules/demux/mkv/mkv.hpp | 1 +
modules/demux/mkv/virtual_segment.cpp | 81 +++++++-------
6 files changed, 267 insertions(+), 210 deletions(-)
Diff: http://git.videolan.org/gitweb.cgi/vlc.git/?a=commitdiff;h=46d18e6bb02d67a1dbf7dd8d0bce5f09a17583cf
More information about the vlc-commits
mailing list