[vlc-commits] vlc_input: Fix misleading parameter name

Hugo Beauzée-Luyssen git at videolan.org
Thu Jan 5 11:34:34 CET 2017


vlc | branch: master | Hugo Beauzée-Luyssen <hugo at beauzee.fr> | Thu Jan  5 11:10:58 2017 +0100| [34a6f140bc2cbbcfe076ceb4feb30264534f1fa3] | committer: Hugo Beauzée-Luyssen

vlc_input: Fix misleading parameter name

input_AddSubtitleOSD expects a file path, not an URL

> http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=34a6f140bc2cbbcfe076ceb4feb30264534f1fa3
---

 include/vlc_input.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/vlc_input.h b/include/vlc_input.h
index c1271c8..fea742e 100644
--- a/include/vlc_input.h
+++ b/include/vlc_input.h
@@ -576,10 +576,10 @@ static inline vout_thread_t *input_GetVout( input_thread_t *p_input )
  * It will add a new subtitle source to the input.
  * Provided for convenience.
  */
-static inline int input_AddSubtitleOSD( input_thread_t *p_input, const char *psz_url,
+static inline int input_AddSubtitleOSD( input_thread_t *p_input, const char *psz_path,
         bool b_check_extension, bool b_osd )
 {
-    int i_result = input_Control( p_input, INPUT_ADD_SUBTITLE, psz_url, b_check_extension );
+    int i_result = input_Control( p_input, INPUT_ADD_SUBTITLE, psz_path, b_check_extension );
     if( i_result != VLC_SUCCESS || !b_osd )
         return i_result;
 



More information about the vlc-commits mailing list