CVS Commit: vlc

Gildas Bazin gbazin at
Mon Feb 25 21:45:47 CET 2002

On Monday 25 February 2002 19:42, cvs at wrote:
> Update of /cvs/videolan/vlc/plugins/dvd
> Modified Files:
> 	dvd.c 
> Update of /cvs/videolan/vlc/plugins/dvdread
> Modified Files:
> 	dvdread.c 
> Update of /cvs/videolan/vlc/src/interface
> Modified Files:
> 	main.c 
> Log Message:
> *Adaptation to new configuration scheme for dvd, dvdread and spdif
> -- 
> stef

Thanks stef for having taken the time to do this conversion :)

I have a few concerns though :P (look at the mail I just sent on the 
configuration architecture).
I also tried to move the title and chapter options but I noticed they were 
used by 3 different plugins (dvd, dvdread and vcd) so I decided to leave them 
in main. Maybe it is not a wise choice, I don't really now if they are 
generic enough to be put in main. But then if they are not, I think they 
should be renamed into something like dvd_title and dvd_chapter (and their 
vcd equivalents).

As I've said in my previous mail, I would like config options to have unique 
names but I must admit the dvd case is really special as we have two plugins 
to do exactly the same thing. Right now the configuration architecture won't 
support identical option names (well... problems will only show off when the 
config file is implemented) but It may actually not be that difficult to 
modify this behaviour. What do you reckon stef ?



This is the vlc-devel mailing-list, see
To unsubscribe, please read
If you are in trouble, please contact <postmaster at>

More information about the vlc-devel mailing list