[vlc-devel] Arm crosscompiling for iPaq

Alessandro Marino a_marino at libero.it
Sun Sep 21 19:46:04 CEST 2003

I tried to compile vlc-0.6.0 for arm following the instructions in file
arm-crosscompile-howto.sgml, but I had many problems.
First, when I run ./bootstrap I get these errors:

cvs [checkout aborted]: no such tag gettext-0_11_5
/usr/bin/autopoint: line 259: fatal_error: command not found
find: tmpwrk4830/archive: No such file or directory
find: tmpwrk4830/archive: No such file or directory

I don't know why bootstrap script can't find autopoint, because it is correctly
installed in /usr/bin directory.

Then I run ./rules with these options:
export CONFIG_FLAGS=--enable-release --prefix=/usr \
	--disable-plugins \
	--enable-gtk \
	--disable-gnome \
	--disable-qt \
	--disable-kde \
	--disable-qte \
	--disable-xosd \
	--enable-dummy \
	--disable-fb \
	--disable-sdl \
	--disable-oss \
	--disable-alsa \
	--enable-x11 \
	--disable-xvideo \
	--disable-dvd \
	--disable-dvdread \
	--disable-vcd \
	--disable-maxosx \
	--disable-xosd \
	--disable-freetype \
	--disable-flac \
	--disable-libmpeg2 \
	--disable-mad \
	--enable-ffmpeg \
	--enable-familiar \
	--disable-dvbpsi \
	--x-includes=/usr/local/arm/3.2.3/arm-linux/usr/X11R6/include \
	--x-libraries=/usr/local/arm/3.2.3/arm-linux/usr/X11R6/lib \
	--with-gtk-config-path=/usr/local/arm/3.2.3/arm-linux/usr/bin \

After configuration process I type make, but I get this output:
make: *** No rule to make target `../config.status', needed by `Makefile'.

How can I solve this problem?

Thanks in advance,

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html
If you are in trouble, please contact <postmaster at videolan.org>

More information about the vlc-devel mailing list