[vlc-devel] Re: Problem compiing vlc SVN on Fedora Core 2

R. Bernstein rocky at panix.com
Sun Aug 22 03:57:55 CEST 2004

Gildas Bazin writes:
 > I'm pretty sure this happens because you have old libvlc headers installed 
 > somewhere (/usr/include or /usr/local/include). These old headers get 
 > picked instead of the ones in your VLC tree.

Many thanks. That did the trick for *compiling*. 

In trying to start with a clean slate I tried "make uninstall" That
worked well enough for the includes. "make clean" from the top level
really didn't clean much. I had to go into the modules directory and
"make clean" from there. Shouldn't make clean in the top-level
directory recurse? 

When I ran vlc, I got a core dumps. On investigation it seems that
"make uninstall" doesn't remove all the broken modules and some of
them were causing core dumps. In particular the dvd module, and the
SDL module (probably among others).

So now, when I run I get a really slick new OSX-like GUI.  But when I
try to test to see if I've fixed what looks to me OGT and CVD subtitle
breakage, I get:

  vlc /src/vcd_examples/svcd_ogt_test_ntsc/avseq01.mpg --spu-channel=0
  VLC media player 0.7.3-svn Bond
  [00000192] main dialogs provider error: no dialogs provider module matched "any"
  [00000191] skins2 interface error: No suitable dialogs provider found
  [00000191] skins2 interface: skin: VLC OSX Interface  author: BigBen
  [00000191] skins2 interface error: Cannot open bitmap /usr/local/share/vlc/skins2/default/reduce_mouseover.png
  [00000191] skins2 interface error: Invalid image size (null width or height)
  [00000198] mpeg_audio decoder: MPGA channels:2 samplerate:44100 bitrate:128
  [00000205] freetype private error: freetype-rel-font currenlty broken, FIXME
  X Error of failed request:  BadAlloc (insufficient resources for operation)
    Major opcode of failed request:  144 (XVideo)
    Minor opcode of failed request:  19 ()
    Serial number of failed request:  71
    Current serial number in output stream:  72

The fact that "currently" is misspelled I think suggests where the freetype
breakage came from ;-)  

As for reduce_mouseover.png, locate shows:


And indeed it is not installed although reduce.png, for example, is. 

Finally, based on a remark Gildas made a while back about fixing the dvb
plugin was all that was needed before another release.

Is this still the impression of most developers? For me right now,
there seems to be a bit that is broken. 

Thanks again for all the help.

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html
If you are in trouble, please contact <postmaster at videolan.org>

More information about the vlc-devel mailing list