[vlc-devel] gdb and vlc

Hussain conundrums at myway.com
Mon Sep 6 09:40:29 CEST 2004

 Hello. This is regarding problems with running VLC in gdb 

In order to get a better understanding of the signaling that takes place in VLC, while its playing back a stream from an RTSP server, I ran VLC 0.7.2, (without any modifications what so ever), in gdb. However VLC is not happy about this and seems to crash. 

I behaviour always seems to be reproducible. 

Described below is the producere I followed: 
First, I run the livedotcom, testOnDemandtestOnDemandRTSPServer server.
Second, I play back the stream using VLC. So far so good. 
Third,  I stop the stream by hitting, the stop button. I then try to play it again, by simply hitting the play button.

gdb then gives me the follwoing error:
> Couldn't get registers: No such process.

If I try to kill the process, I get the following output:
>(gdb) kill
>Kill the program being debugged? (y or n) y
>thread_db_get_info: cannot get thread info: generic error

I did enable the debug options, and disable the optimization options while configuring Suse 9.1, and have gdb version 6.1 installed. The above errors occur, with the distributed VLC code. I had NOT made any modifications to the code.

Any help in resolving this matter will be greatly appreciated. 

Thank you. 


No banners. No pop-ups. No kidding.
Make My Way your home on the Web - http://www.myway.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20040906/5c54c707/attachment.html>

More information about the vlc-devel mailing list