[vlc-devel] Problems of compiling vlc-0.8.2 in Fedora Core 3

Zhang, Yonghang yzhang at belcan.com
Tue Nov 22 17:28:19 CET 2005

Hi all,
I am new to vlc-0.8.2 and I tried to compile vlc-0.8.2 in Fedora Core3.
But I had some problems.
First, I typed in the following command:
./configure --enable-v4l --enable-ffmpeg
--with-ffmpeg-tree=/usr/lib/ffmpeg --enable-faac --disable-mkv 


It worked fine and generated config.h file.

Second, I typed in 'make', then I got the following message:

g++ -Wsign-compare -Wsign-compare -Wall -pipe -o libmod_plugin.so
libmod_plugin_a-mod.o `top_builddir=../.. ../../vlc-config --libs plugin

/usr/bin/ld: cannot find -lmodplug

collect2: ld returned 1 exit status

make[4]: *** [libmod_plugin.so] Error 1

make[4]: Leaving directory `/home/videoproject/vlc-0.8.2/modules/demux'

make[3]: *** [all-modules] Error 1

make[3]: Leaving directory `/home/videoproject/vlc-0.8.2/modules/demux'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/home/videoproject/vlc-0.8.2/modules'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/videoproject/vlc-0.8.2'

make: *** [all] Error 2


I don't know why it failed. I sincerely appreciate if somebody can share
some lights on it. Thanks



The information transmitted is intended only for the person(s) or entity to which it is addressed and may contain sensitive and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient(s) is prohibited. If you received this in error, please contact the sender and destroy any copies of this document.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20051122/50790528/attachment.html>

More information about the vlc-devel mailing list