[vlc-devel] ffmpeg aac decoding

Diego 'Flameeyes' Pettenò flameeyes at gentoo.org
Sat Jun 17 01:26:22 CEST 2006

I had some hard time tongiht with VLC on Gentoo because of AAC decoding gone 
crazy. I think it might be related to the fact that we had to patch faad to 
work on 64-bit systems and that caused a few problems with API/ABI.
As faad is always a headache to deal with, I tried to find alternatives to 
trying to track down the issue, and I found that ffmpeg's decoder is skipped 
and told broken. I tried myself with our latest ffmpeg snapshot, and instead 
it works just fine, so I patched it to remove the aac blacklisting, and 
that's working fine. Right now I just disable faad support in VLC and leave 
it to ffmpeg to decode it.

There's a good side effect: in a couple of months ffmpeg is likely to get its 
own AAC decoder that would work probably better than faad (as that is really 
a big, great trouble), and doing this way, it will be used when available.

Now, I'm not sure what would be a good course of action for the upstream 
sources, but what would have been the problem with ffmpeg's aac decoder? 
Might it be so old that it's now fixed anyway? Version conditionals?

Diego "Flameeyes" Pettenò - http://farragut.flameeyes.is-a-geek.org/
Gentoo/Alt lead, Gentoo/FreeBSD, Video, AMD64, Sound, PAM, KDE
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20060617/c9db12fb/attachment.sig>

More information about the vlc-devel mailing list