[vlc-devel] framebuffer video MIPS

kartikay malhotra kartikay.malhotra at gmail.com
Fri Nov 24 04:19:44 CET 2006

Hi folks,

I am trying to port VLC to MIPS and I've been able to play audio files.
However I wish to display video, which gives the following error:
/ # ./vlc xyz.mpeg
[00000273] fb video output error: cannot get terminal mode (Invalid
(hard coded in fb.c)

I do not have X/ Qt/ wxwidgets support. I must use framebuffer. I compiled
Directfb support into VLC.

I googled, only to find a very similar problem in the videolan archives at

1. Taking clue from the suggestions, I changed p_vout->p_sys->i_tty  from 0
to 1, but it did nothing.
2. Changed permission of /dev/fb0-4 and /dev/tty0 to 777. Same error.
3. I tried fbio /dev/fbx enable 0, where x=0->3. No change.

My frame buffer is working. I can cat dummy_pic > /dev/fb0 and I see changes
on screen.

All suggestions are welcome with gratitude.

Er. KM
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20061124/567813eb/attachment.html>

More information about the vlc-devel mailing list