[vlc-devel] RTSP streaming broken in trunk when using transcode (maybe just on OSX?)

Brian Raymond braymond at echostorm.net
Tue Sep 26 15:16:17 CEST 2006

Initially I thought RTSP streaming was simply broken because I kept  
getting the following when connecting from VLC:

trunk compiled with XCode 2.4 or nightly build
OSX 10.4.7
PowerMac G5 2GHz

Streaming using one of the following commands:

[00000297] main http server debug: Connection from
[00000309] main private debug: looking for sout access module: 1  
[00000309] main private debug: set sout option: sout-udp-raw to (null)
[00000309] main private debug: net: connecting to port  
[00000310] main private debug: thread 68402176 (sout write thread)  
created at priority 37 (udp.c:268)
[00000309] access_output_udp private debug: udp access output opened 
[00000309] main private debug: using sout access module  
[00000309] main private debug: thread 68402176: secret message  
triggered at misc/block.c:228 (Operation timed out)

I only tried MPEG2, and H.264 sources here so this is not all  
inclusive however with an MPEG2 source and no transcode (#rtp 
{sdp=rtsp://}) the same error is thrown when a  
client tries to connect. With a H.264 source and no transcode (#rtp 
{sdp=rtsp://})  it will stream to the client  
without issue.

Found the same issue with 0.8.5 however 0.8.4a seems to work for mp4v.

- Brian

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list