[vlc-devel] Re: Wget needed to build extras/contrib twolame?

Mark Moriarty mfmbusiness at earthlink.net
Sun Mar 4 18:11:53 CET 2007

Yes, I ran bootstrap.
I did not have Cygwin's wget.  I downloaded it, reran the build, it worked
Overall, since curl is already needed for other package(s), I'd recommend
removing use of wget, use curl or the other mechanism(s) already used for
the multitude of other libs.  Tacking on multiple fetch packages is just
kind of ugly, adds yet more gubbage to creation of a build environment.
It's a philosophical thing, trying to keep the environment from being
cluttered with more things than are needed.
I was very impressed -- a lot of nice work has clearly been done on the lib
build process, it was pretty clean under Cygwin.  There were one or two
"burps", things where the build would fail due to some files, things that
occured when processing "rm -f" kinds of commands.  A restrrt would recover
I've noticed a fair number of subversion-related errors when running updates
over the last 24 hours, mismatched checksums being reported.  Again, redoing
the update would generally clear things (though I had to kill-and-fill the
Mac gui section).
I'm running the build on the trunk, will be interested to see if it's now
going to be OK or if I run into the old configure.ac problem.  As of last
Fall I had to change line 305:

To match my actual gettext version (e.g., 0.15) -- something about that line
introduced an error when your actual gettext was newer than the configure.ac
line 305.
Also, has the build environment been updated so under cygwin one can use
newer binutils?  I've still got the 2005 package installed, just curious.


From: vlc-devel-bounce at videolan.org [mailto:vlc-devel-bounce at videolan.org]
On Behalf Of Michel Jansen
Sent: Sunday, March 04, 2007 11:48 AM
To: vlc-devel at videolan.org
Subject: [vlc-devel] Re: Wget needed to build extras/contrib twolame?

On 04 Mar 2007, at 02:59, Mark Moriarty wrote:

I did find wget, but it still looks like it ends up tracing to a subversion

Did you run the bootstrap system first? This is supposed to autoconfigure
your download command. If wget isn't working, try swapping the WGET command
in config.mak to "curl -O" instead of wget :)

Kind regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20070304/837f5062/attachment.html>

More information about the vlc-devel mailing list