[vlc-devel] [RFC] Remove vlc_bool_t in favor of bool

Pierre d'Herbemont pdherbemont at free.fr
Sun Apr 13 22:43:26 CEST 2008


Currently vlc_bool_t is an alias for 'bool' which is the std C++/C99  

I am in favor of replace vlc_bool_t by bool and VLC_TRUE by true, and  
VLC_FALSE by false to ease readability.

Note that currently we have:
#define VLC_FALSE false
#define VLC_TRUE true

What do you think?


More information about the vlc-devel mailing list