[vlc-devel] [RFC] Remove vlc_bool_t in favor of bool

Jean-Paul Saman jpsaman at videolan.org
Mon Apr 14 08:51:55 CEST 2008

Pierre d'Herbemont wrote:
> Hi,
> Currently vlc_bool_t is an alias for 'bool' which is the std C++/C99  
> type.
> I am in favor of replace vlc_bool_t by bool and VLC_TRUE by true, and  
> VLC_FALSE by false to ease readability.
> Note that currently we have:
> #define VLC_FALSE false
> #define VLC_TRUE true
> What do you think?

Does beos, solaris, QNX and other ports support it ?

Jean-Paul Saman

More information about the vlc-devel mailing list