[vlc-devel] segmentation fault-while running with multiproto drivers for dvb (NOT PLAYING ANY MEDIA FILE ALSO)

anand meher kvmsanand at gmail.com
Wed Aug 6 14:54:48 CEST 2008

Hi ,
       I used the following configuration script and compiled vlc 0.9.0(git

./configure  '--enable-debug' '--enable-release' '--enable-pvr'
'--enable-dvb' '--enable-httpd' '--disable-skins2' '--disable-qt4'
'--disable-live555' '--disable-v4l2' '--enable-v4l'

   vlc compiles only if i diable v4l2 support and enable v4l suuport,
otherwise make shows some errors.

and the when i run vlc with a media file it shows the follwing errors.

anand at linux-h2dx:/usr/local/bin> gdb ./vlc
GNU gdb 6.5
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-suse-linux"...Using host libthread_db
library "/lib64/libthread_db.so.1".

(gdb) r /home/anand/Desktop/bbc.ts
Starting program: /usr/local/bin/vlc /home/anand/Desktop/bbc.ts
[Thread debugging using libthread_db enabled]
[New Thread 140532192675568 (LWP 21566)]
VLC media player 0.9.0 Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.0 Grishenko -
(c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure
'--enable-debug' '--enable-release' '--enable-pvr' '--enable-dvb'
'--enable-httpd' '--disable-skins2' '--disable-qt4' '--disable-live555'
'--disable-v4l2' '--enable-v4l'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Found old config file at /home/anand/.vlc/vlcrc. VLC
will now use /home/anand/.config/vlc/vlcrc.
[New Thread 1105574208 (LWP 21569)]
[New Thread 1113966912 (LWP 21570)]
[New Thread 1095125312 (LWP 21571)]
[New Thread 1122359616 (LWP 21572)]
[New Thread 1130752320 (LWP 21573)]
[New Thread 1139145024 (LWP 21574)]
[New Thread 1147537728 (LWP 21575)]
[New Thread 1082382656 (LWP 21576)]
[New Thread 1155930432 (LWP 21577)]
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc'
to use vlc without interface.
Remote control interface initialized. Type `help' for help.
[New Thread 1164323136 (LWP 21578)]
[New Thread 1172715840 (LWP 21579)]
Error while reading shared library symbols:
DW_FORM_strp pointing outside of .debug_str section [in module

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1172715840 (LWP 21579)]
0x00007fd02224de1b in ?? () from
(gdb) bt
#0  0x00007fd02224de1b in ?? () from
#1  0x00007fd02223cbbb in ?? () from
#2  0x0000000580007fd0 in ?? ()
#3  0x2223bd9100000003 in ?? ()
#4  0x00832de000007fd0 in ?? ()
#5  0x006b836800000000 in ?? ()
#6  0x0083579800000000 in ?? ()
#7  0x3307fa5600000000 in ?? ()
#8  0x330a7ac000007fd0 in ?? ()
#9  0x002c9d7800007fd0 in ?? ()
#10 0x00832c9000000000 in ?? ()
#11 0x0000000000000000 in ?? ()

its the same error which appeared earlier?? i dont know which libraries are
missing , any help would be appreciated..

thanks in advance


On Wed, Aug 6, 2008 at 2:07 PM, Gregor Fuis <gujs.lists at gmail.com> wrote:

> On Wed, Aug 6, 2008 at 1:47 PM, anand meher <kvmsanand at gmail.com> wrote:
>> HI Gregor,
>>                The satellite i am using is Thor1.0 W and the TV-tuner card
>> i am using is TT-budget S2-3200 which is a DVB-S2 card. But just now what i
>> observed was that the vlc fails to play even simple media files. I ran a gdb
>> and the dump is given beloew. GDB says there is some problem with resolving
>> the shared library symbols :(.
>>                  i am afraid if i have done something wrong with
>> compilation , I used
>>        ./configure  '--disable-qt4' '--disable-skins2' '--disable-v4l2'
>> '--enable-v4l' 'CPPFLAGS=-I/build/multiproto_plus/linux/include'
> I have used this configuration for compiling:
> CPPFLAGS="-I/home/iptv/iptv-source/packages/multiproto/multiproto-fbcc9fa65f56/linux/include"
> ../configure --enable-debug --enable-release --enable-pvr --enable-dvb
> --enable-httpd --disable-skins2 --disable-qt4 --disable-live555
> Maybe you use to old libraries or something. I have Ubuntu 8.04 and did
> apt-get build-dep vlc for getting the right libraries.
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080806/72cbedcd/attachment.html>

More information about the vlc-devel mailing list