[vlc-devel] Testing the VLC Nightly Build

Jean-Baptiste Kempf jb at videolan.org
Mon Aug 11 21:31:30 CEST 2008

On Mon, Aug 11, 2008 at 03:25:20PM -0400, komputes wrote :
> I just tested the i386 nightly build for Ubuntu Hardy 8.04. The version
> is 0.9.0-test3 Grishenko. I have a few things that I would like to see
> fixed.
> 1) User Interface - volume and play button should remain the same size
> as other buttons.
This is discutable.

> 2) User Interface - Playing Video Fullscreen: Preferences option to take
> off the on screen display of buttons to control the video.
There is already it in the latest code.

> 3) User Interface - I have lost all drag and drop functionality. 
> Dragging files to the playlist does not add them to the playlist.
I know, will be fixed before the release.

> 4) Video Capture device shows as wrong color (mostly purple). Device ID:
> [046d:08a9 Logitech, Inc.] The actual device  is a Logitech QuickCam for
> Notebooks Deluxe.
v4l ?

> 5) Transcoding - I have an issue converting FLV -> MPEG-4 and I wonder
> if I should create a bug for that. I posted the issue on the forums:
> http://forum.videolan.org/viewtopic.php?f=13&t=49027
> I was told by feepk, a fellow developer that I want to try out 0.9.0
> pre-release build since it includes various fixed on Flash processing.
> I downloaded the Ubuntu Hardy I386 version using the instructions from
> http://nightlies.videolan.org/
> With this version I can no longer transcode. The transcoder adds the
> task to the playlist, and play the task which it names "Streaming", but
> the "progress" bar does not move and there is no outputs no file! The
> program does not request an output file name. I tried to convert an FLV
> Video to MP4/ACC and I tried the iPod preset. As you can see in these
> presets theres is nothing concerning an output file:
> :sout=#transcode{vcodec=mp1v,vb=800,scale=0.25,acodec=mpga,ab=128,channels=2}
> :sout=#transcode{vcodec=mp4v,vb=800,scale=0.25,acodec=mpga,ab=128,channels=2}
> With the help of feepk I manually changed that to fit a path on my
> computer user (ubuntu) to be used for the output file.
> :sout=#transcode{vcodec=mp4v,vb=1024,acodec=mp4a,ab=192}:standard{mux=mp4,dst=/home/ubuntu/Desktop/test.mp4,access=file}
> This still did not work and when I tried transcoding a file
> (flashvideo.flv). The output file (test.mp4) was 201 bytes. I looked at
> the messages saw the following errors.
> File reading failed:
> VLC could not open the file ""/home/ubuntu/Desktop/flashvideo.flv" ".
> Your input can't be opened:
> VLC is unable to open the MRL '"/home/ubuntu/Desktop/flashvideo.flv" '.
> Check the log for details.
> Please feel fee if you would like more detailed debugging information or
> testing on my part.
What DAY was your build? This has been fixed some time ago.

Best Regards,

Jean-Baptiste Kempf

More information about the vlc-devel mailing list