[vlc-devel] Fwd: Re: [vlc] bug in VLC 0.9x - crashing playback with streaming

Rémi Denis-Courmont rdenis at simphalempin.com
Wed Dec 10 07:35:28 CET 2008

-------- Original Message --------
Subject: Re: [vlc] bug in VLC 0.9x - crashing playback with streaming
Date: Tue, 9 Dec 2008 22:58:00 +0100
From: "Martin" <martin at volyne.cz>
To: Rémi Denis-Courmont <rem at videolan.org>

of course, my english is not good... but will not be better. Better can be
czech only :-) Lets go look for problems in VLC and not in my english :-)

Once again:

I am using VLC for streaming movies from PC to Dreambox ( Dreambox =
satellite receiver with Linux) with Movieplayer plugin. Understand ?

Movieplayer-plugin sending for each playback of file the commands ( with
/?control= ...):  stop, empty, sout, add&mrl, play. Understand ?

With v. 0.9.x there are problem - first two files are played wel. If begin
3rd file, then on command "play" VLC crashing always.

If I tried add more files into playlist and then streaming this files, then
on 3rd file VLC crashing too.

If I am trying all same without "sout" ( =  files arent streamed and are
played on PC only), all works well => problem will be some in streaming


----- Original Message -----
From: "Rémi Denis-Courmont" <rem at videolan.org>
To: <vlc at videolan.org>
Cc: "Martin" <martin at volyne.cz>
Sent: Tuesday, December 09, 2008 5:16 PM
Subject: Re: [vlc] bug in VLC 0.9x - crashing playback with streaming

Sorry, I don't understand your problem.
Please use proper English.

Le lundi 1 décembre 2008 11:39:35 Martin, vous avez écrit :
> Hello,
> I am movieplayer's developer for Dreambox satelite firmware (Pli team). I
> have problem with streaming from VLC 0.9x into dream, because in version
> 0.9x is there bug. Version 0.86 was ok ( there was little bug, but it was
> possible solve ) . VLC is run with parameter  --intf
> wxwin --extraintf=http
> Version 0.9x crashed always, if i try playback 3rd file ( only, if is
> streaming with "sout=...").
> How works Movieplayer: - each selected file from list in movieplayer is
> send to playlist in VLC, played, removed.
> my sequencions for one playback:
> -------------------------------------------------
> stop  ( if VLC playback - stop it )
> empty (empty playlist )
> sout = ......  send parameter for streaming (bitrate, subtitle yes/no,
> sync
> yes/no, ts,  ... etc ... ) - for each file type it can be different add
> mrl
> - added file mrl into playlist
> play  - run playback = streaming
> I can playback only 2 file. If i starting 3rd sequention, after PLAY
> command VLC0.9x always crashing  - libvlccore.dll
> I tried it without "sout" parameter => ( was not streamed ofcourse, was
> only played on PC) and there is all ok. => must be bug in playback and
> streaming.
> Can be repaired in near time ? I cannot finished Movieplayer for 0.9x
> still. I tried 0.97 from 30.12.2008 and same.
> ( Note: I tried 1.0 too - there is not possible run VLC with --intf wxwin
> --extraintf=http - VLC dont start. If i set http in VLC, next start was
> impossible. Bad news for me... )
> Best regards
> Martin S. (ims)

Rémi Denis-Courmont
Rémi Denis-Courmont

More information about the vlc-devel mailing list