[vlc-devel] running vlc with sudo

Gregor Fuis gujs.lists at gmail.com
Wed Jul 9 10:15:00 CEST 2008

On Wed, Jul 9, 2008 at 8:16 AM, Gregor Fuis <gujs.lists at gmail.com> wrote:

> Hello,
> I have a problem running vlc with sudo. I tried it with vlc-wrapper but it
> doesn't want to read dvb adapter when it is started with sudo. Do I have to
> specify somewhere which user can run vlc with vlc-wrapper and have all
> permissions. I would really appreciate any help about that.
> I was running vlc 0.8.6 with sudo without any problems before.
> Here is the log of vlc running wirh sudo:
> main libvlc debug: VLC media player - version 0.9.0-test2 Grishenko - (c)
> 1996-2008 the VideoLAN team
> [00000001] main libvlc debug: libvlc was configured with ../configure
> '--prefix=/usr' '--enable-debug' '--disable-qt4' '--disable-skins2'
> [00000001] main libvlc debug: translation test: code is "C"
> [00000357] inhibit interface error: Failed to connect to the D-Bus session
> daemon: dbus-launch failed to autolaunch D-Bus session: Autolaunch error:
> X11 initialization failed.
> [00000357] main interface error: no suitable interface module
> [00000001] main libvlc error: interface "inhibit,none" initialization
> failed
> [00000361] logger interface: using logger...
> [00000364] telnet interface: using the VLM interface plugin...
> [00000364] telnet interface: telnet interface started on interface  40000
> [00000366] [Media: ch] dvb access error: FrontendOpen: opening device
> failed (Permission denied)
> [00000352] [Media: ch] main input error: open of `dvb://' failed: could not
> create access
> Thanks for any help.
> Gregor

I solved my problem. I just had to add root user to video group.

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080709/0d02f688/attachment.html>

More information about the vlc-devel mailing list