[vlc-devel] ASA support : unable to link with 64 bits CSRI library

Gilles Sabourin gilles.sabourin at free.fr
Sun Jun 15 17:30:05 CEST 2008


I know that Rafaël Carré have participated to ASA (can see "fix ASA building" 
on last march 2008 when looking to web git page...) and Dominique Leuenberger 
have packaged this library. I wonder if they are still concerned people.

Anyway, this is for information, since I have no contact with ASA developpers 
and no account : I have successfully compiled 32 bits vlc with CSRI, but this 
library fails to link on my 64 bits PC (tried also to compile it from git 
repository, with same result). I guess there is a missing -fPIC somewhere at 
CSRI compilation time :

mv -f .deps/libcsri_plugin_la-csri.Tpo .deps/libcsri_plugin_la-csri.Plo
/bin/sh ../../libtool --tag=CC   --mode=link gcc -std=gnu99 
`top_builddir="../.." ../../vlc-config --cflags plugin 
libcsri_plugin.la` -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -rpath '/usr/lib64/vlc/codec' -avoid-version -module -no-undefined -export-symbol-regex 
^vlc_entry -shrext .so `top_builddir="../.." ../../vlc-config --ldflags 
plugin libcsri_plugin.la`  -o libcsri_plugin.la  libcsri_plugin_la-csri.lo  
`top_builddir="../.." ../../vlc-config -libs plugin 
libcsri_plugin.la` ../../src/libvlccore.la
gcc -std=gnu99 -shared  .libs/libcsri_plugin_la-csri.o  -Wl,--rpath -Wl,/usr/src/packages/BUILD/vlc-beta-0.9.0/src/.libs /usr/lib64/libcsri.a -lpthread ../../src/.libs/libvlccore.so -L/lib64 -L/usr/lib64  -Wl,-soname -Wl,libcsri_plugin.so -o .libs/libcsri_plugin.so
/usr/lib64/gcc/x86_64-suse-linux/4.2.1/../../../../x86_64-suse-linux/bin/ld: /usr/lib64/libcsri.a(libcsri_la-list.o): 
relocation R_X86_64_32S against `a local symbol' can not be used when making 
a shared object; recompile with -fPIC
/usr/lib64/libcsri.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[5]: *** [libcsri_plugin.la] Error 1
make[5]: Leaving directory 
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory 
make[3]: *** [all] Error 2
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/packages/BUILD/vlc-beta-0.9.0/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/packages/BUILD/vlc-beta-0.9.0'
make: *** [all] Error 2

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 194 bytes
Desc: This is a digitally signed message part.
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080615/ce6d89e4/attachment.sig>

More information about the vlc-devel mailing list