[vlc-devel] problems building vlclib 0.9.6 on OS X

Stjepan Rajko stjepan.rajko at gmail.com
Sun Nov 9 22:40:47 CET 2008


I am trying to build libvlc from the 0.9.6 source download, on OS X
(leopard).  This is a part of my ongoing efforts to use libvlc in an
application - I am very excited about libvlc, but linking to it
successfully seems to be rather elusive for me :-)

I am following the instructions here:

I have some questions / problems I ran into.  My first question is
about getting the source tarball vs. the current version using git.
The instructions say "Note that the 3rd party libraries will probably
break a few months after the release's publication".  I don't
understand why this is a problem, since your extras/contrib script
appears to download specific versions of library dependencies.
Shouldn't it always download the versions that are appropriate for the
tarballed release?

Since 0.9.6 is pretty recent, I optimistically went forward with
building from the release.  The "Build external libs" step went fairly
well.  Do disable fink, the instructions indicated I should modify
.cshrc or .bashr, but I have neither of those files - I needed to
update .profile.

I also ran into an error at one point:

/usr/bin/curl -L -O http://live555.com/liveMedia/public/live555-latest.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  434k  100  434k    0     0   420k      0  0:00:01  0:00:01 --:--:--  800k
rm -rf live || true
gunzip -c live555-latest.tar.gz | tar xf - --exclude='[*?:<>\|]'
mv live555-latest live || true
mv: rename live555-latest to live/live555-latest: No such file or directory
touch live
patch -p0 < Patches/live-noapps.patch
patching file live/Makefile.tail
patch -p0 < Patches/live-uselocale.patch
patching file live/liveMedia/include/Locale.hh
patching file live/liveMedia/Locale.cpp
patching file live/liveMedia/RTSPClient.cpp
Hunk #1 succeeded at 1019 (offset 2 lines).
Hunk #2 succeeded at 1033 (offset 2 lines).
Hunk #3 succeeded at 2342 (offset 36 lines).
patching file live/liveMedia/RTSPCommon.cpp
Hunk #1 FAILED at 146.
1 out of 1 hunk FAILED -- saving rejects to file
patching file live/config.mingw
make[1]: *** [live] Error 1
make: *** [all] Error 2

I re-ran make and it continued, without any further problems.  I hope
that patch hunk was not essential :-)

Some questions:

The instructions say "Now execute make. This will download prebuilt
binary contrib you can happily use to build VLC wth -- only if you're
using git master branch."  What are you supposed to do if you are not
using the git master branch?  Also, I am not clear why it says that it
will download prebuilt binary contrib when in fact it appears to be
downloading and compiling a whole bunch of things.

The instructions do mention "If you're trying to build some release
from 0.9 series, you need to execute: make src" but this doesn't work
(make: Nothing to be done for `src'.).  I also remember seeing on some
page that you can do "make bin" but that didn't work either.


I then went to the top-level VLC directory and ran "./configure
--enable-debug --with-macosx-sdk" as per instructions.  The script
quit with an error saying it can't find the "QuickTime/QuickTime.h"
header.  I have the Quicktime framework installed.  I am not very
knowledgeable about autoconf/configure, but I tried editing the
configure.ac script to disable this header check (but still use the
framework) and re-ran autoconf. I was then informed that I am using a
different version of autoconf (2.60) when the other scripts were
created using 2.61... The result didn't work, and neither did running
autoreconf (both resulted in an early error running configure).

Any suggestion on what to try next?



More information about the vlc-devel mailing list