[vlc-devel] cygwin build

nick.parker at chequeredvideo.com nick.parker at chequeredvideo.com
Wed Nov 19 10:49:39 CET 2008

Hi all

I am planning to work on fixing some issues in the Windows version and am
in the process of getting my development environment together.  Yesterday
I downloaded the latest git version into a cygwin environment and once
taglib was disabled it built successfully.

However, when I come to run the executable from within the build area I
have problems.  ( I have done 'make' and then 'make install').  If I cd
into bin and run ./vlc from within the cygwin shell then the shell hangs,
if I run ./vlc-static then the command return.  If I run './vlc-static
file://myvid.mp4' then I see a vlc-static process but no video is player. 
Also at any time I never get the GUI loading up.

I have read the two instructions on building in cygwin.  In the past I
have successfully built the player however there was a separate directory
called vlc-x-x-x created by the build process which contained all that is
required to run the player and this is not present in the latest git
release - maybe something fundamental has changed.

I expect I am doing something stupid so a little help would be much
appreciated so that I can take a look at some of the real bugs.

Many thanks


More information about the vlc-devel mailing list