[vlc-devel] JVLC maven tests failing.

Tony Anecito adanecito at yahoo.com
Sat Jan 3 21:01:40 CET 2009

Hi JVLC Team,

Here is an example of the test failure. Seems the dlls for vlc are not being found? Is there a special place they should be put for the maven tests to find them?

Still would like to know where to get the jna files for eclipse testing.


Tests run: 3, Failures: 0, Errors: 3, Skipped: 0, Time elapsed: 0.016 sec <<< FAILURE!
testNew(org.videolan.jvlc.internal.LibVlcCoreTest)  Time elapsed: 0 sec  <<< ERROR!
java.lang.NoClassDefFoundError: Could not initialize class org.videolan.jvlc.internal.LibVlc
	at org.videolan.jvlc.internal.LibVlcCoreTest.<init>(LibVlcCoreTest.java:37)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at org.junit.internal.runners.JUnit4ClassRunner.createTest(JUnit4ClassRunner.java:72)
	at org.junit.internal.runners.JUnit4ClassRunner.invokeTestMethod(JUnit4ClassRunner.java:79)
	at org.junit.internal.runners.JUnit4ClassRunner.runMethods(JUnit4ClassRunner.java:51)
	at org.junit.internal.runners.JUnit4ClassRunner$1.run(JUnit4ClassRunner.java:44)
	at org.junit.internal.runners.ClassRoadie.runUnprotected(ClassRoadie.java:27)
	at org.junit.internal.runners.ClassRoadie.runProtected(ClassRoadie.java:37)
	at org.junit.internal.runners.JUnit4ClassRunner.run(JUnit4ClassRunner.java:42)
	at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
	at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:338)
	at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:997)

--- On Sat, 1/3/09, Tony Anecito <adanecito at yahoo.com> wrote:

> From: Tony Anecito <adanecito at yahoo.com>
> Subject: [vlc-devel] JVLC maven tests failing.
> To: vlc-devel at videolan.org
> Date: Saturday, January 3, 2009, 12:49 PM
> Hi JVLC team,
> I tried using maven2 and using intall directive it failed
> on the testing. Seems as if the compile worked. I did notice
> the jna files failed checksum so that might be the root
> cause.
> I could not locate where maven put the jna files. I am
> interested in getting the jna jars since the compile fails
> for me in Eclipse because of the special option for the
> libraries for jna that was added to the jna jar.
> The jna files are not part of the git download so I could
> only get them through the maven2 download/build/test
> process.
> Thanks,
> -Tony
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel


More information about the vlc-devel mailing list