[vlc-devel] [PATCH] Add marq filter to libvlc

Pierre d'Herbemont pdherbemont at free.fr
Wed Jun 17 18:58:33 CEST 2009


This structure name does not follow the usual libvlc naming scheme.

Plus, exposing a direct structure is a bit suspicious, especially in
this case where an option is being used to. And it is highly likely
that user will forget to free() the psz_text member of this structure.

What about something like:

libvlc_video_set_marq_text(const char * text);
char * libvlc_video_get_marq_text(const text); // Caller has to free()

libvlc_video_set_marq_option(libvlc_video_marq_option_t option,
libvlc_video_marq_value_t value);
libvlc_video_get_marq_option(libvlc_video_marq_option_t option,
libvlc_video_marq_value_t value);

libvlc_video_marq_value_t being a int.


On Wed, Jun 17, 2009 at 4:39 AM, Cyril
MATHE<cmathe at actech-innovation.com> wrote:
> libvlc_video_get_marq : return a marq_cfg_t object
> libvlc_video_set_marq : set a marq_cfg_t object (enable filter and
> option choosen)
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel

More information about the vlc-devel mailing list