[vlc-devel] commit: Added picture_pool_NewExtended. (Laurent Aimar )
fenrir at via.ecp.fr
Tue Sep 8 09:18:43 CEST 2009
On Tue, Sep 08, 2009, Pierre d'Herbemont wrote:
> On Sep 7, 2009, at 11:05 PM, "Rémi Denis-Courmont" <remi at remlab.net>
>> Le lundi 7 septembre 2009 23:57:52 Pierre d'Herbemont, vous avez écrit
>>> In this case NewWithConfiguration seems more appropriate. And
>>> "configuration" should probably be "callback".
>> Do you really need to invent the longest possible names all the time?
> You are just saying, that short is good. And I do agree.
> However someone new to the code will appreciate meaningful and clear
> name. I am always open to better suggestion.
> Also, if you want to put it that way, Extended is a waste of 8 chars.
> I am concerned about this "lazy" way to extend existing API. And it
> shouldn't be considered as a good practice, even if it's a common one.
> Will you end up with an ExtendedExtended if you want a more specialized
No, picture_pool_configuration_t simply need to be extended.
> Generally the extended and non extend should be merged, or just renamed.
I prefer to have 2 functions:
- one that will allow to be extended easily. picture_pool_NewExtended will do,
it just a matter of extending picture_pool_configuration_t.
- one that is easy to use (and it is the common use case), picture_pool_New.
More information about the vlc-devel