[vlc-devel] Tracking down issue with 1.1.

Tony Anecito adanecito at yahoo.com
Sun Apr 25 06:19:58 CEST 2010

Hi All,

Tracked down further the issue with "Unknown Event". Since I tried switching to 1.1 from 1.0.6 I ran into this error. Now I know it occurs the first time I call libvlc_event_attach (in event.c) with a value of 10 for the event_type. For some reason in 1.0.6 the event name for that value is found but not for 1.1.0. The code changed significantly in this area from 1.0.6 so not sure why the event name is not found.

Anyone know why I would get this error? Did libvlc_event_type_t change from an int to something else?


----- Original Message ----
From: Tony Anecito <adanecito at yahoo.com>
To: vlc-devel at videolan.org
Sent: Thu, April 22, 2010 9:09:19 PM
Subject: [vlc-devel] (no subject)

Okay I am getting further with the error trying to use 1.2 vlc libs. I get the following last set of lines before I get an error in the control/event.c 

[037518e0] main access debug: removing module "filesystem"
[03736458] main input debug: Destroying the input for 'Media Library'
[03736458] main input debug: TIMER input launching for 'Media Library' : 18.000 ms - Total 18.000 ms / 1 intvls (Avg 18.000 ms)
[0373eae0] main interface debug: looking for interface module: 2 candidates
[0373eae0] main interface debug: using interface module "hotkeys"
[0373eae0] main interface debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
This object event manager doesn't know about 'Unknown Event' events

I am not sure what vlc is trying to say on the last line. But I think I am closer to the root cause.


vlc-devel mailing list
To unsubscribe or modify your subscription options:


More information about the vlc-devel mailing list