[vlc-devel] [PATCH] Tries to fix possible deadlock in libavcodec.

Hans-Kristian Arntzen maister at archlinux.us
Thu Aug 12 00:45:17 CEST 2010

  Using the latest git version, VLC would always hang when seeking in a 
video containing H.264 video. The UI would be functional, but to kill 
the application I had to resort to kill -9. It seems that VLC now 
supports multithreaded operation in libavcodec. (I have ffmpeg-mt). It 
worked just fine in 1.1.2.

I found that it would always hang in a certain wait() call in 
modules/codec/avcodec/video.c, and commenting this one out made seeking 
working again. Problem is that I have no idea why this worked.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Tries-to-fix-possible-hang-in-decoding-thread-when-s.patch
Type: text/x-patch
Size: 953 bytes
Desc: not available
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20100812/6492f5bb/attachment.bin>

More information about the vlc-devel mailing list