[vlc-devel] Problems with libmodplug when compiling VLC 1.1 on Mac OS X

David Blishen d at vidblishen.com
Sun Jul 18 12:42:40 CEST 2010


I've been working on a small app using VLCKit. I've never actually successfully built VLCKit, so the framework I am using at the moments was copied from inside the latest Lunettes.app.

I'd like to update my VLCKit to the latest so I am having another go at building VLC and VLCKit.

I am trying to follow http://wiki.videolan.org/OSXCompile, but having some trouble.

The environment is:

Mac OS 10.6.4
XCode 3.2.2
MacBook Pro 2.53

Here are my steps:

cd ~/

export CC=/Developer/usr/bin/llvm-gcc-4.2
export CXX=/Developer/usr/bin/llvm-g++-4.2
export OBJC=/Developer/usr/bin/llvm-gcc-4.2

git clone git://git.videolan.org/vlc-1.1.git

mv vlc-1.1 vlc

cd vlc/extras/contrib

./bootstrap x86_64-apple-darwin10


cd ../..


Up to this point, everything looks fine, however when I run:

./configure --enable-debug  --build=x86_64-apple-darwin10

It exits with this error:

configure: error: libmodplug version 0.8.8 will not work. Please upgrade to or later (or downgrade to 0.8.7)!

I tried to get libmodplug from http://sourceforge.net/projects/modplug-xmms/files/libmodplug/, but couldn't work out what to do next.

Any suggestions?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20100718/3f99858d/attachment.html>

More information about the vlc-devel mailing list