[vlc-devel] Unable to build npvlc.dll

Rafaël Carré rafael.carre at gmail.com
Thu Oct 28 14:47:55 CEST 2010

On Thu, 28 Oct 2010 02:44:41 -0700
"gozer at progrock.com" <gozer at progrock.com> wrote:

> I'm trying the cross-build of VLC on Linux for Windows (on the latest
> git source tree).
> During make package-win32 , 2 modules are fetched via git

> (why not before ?)

Because they are not needed to build VLC itself

> ... After fetching (via gitweb because I don't have git
> access behind my firewall, and because these 2 git trees are not
> mirrored on http://repo.or.cz/ !) activex-vlc and npapi-vlc, I have a
> problem building in npapi-vlc:
> % make stamp-npapi-build CONTRIB_DIR=/usr/win32
> /bin/sh ../libtool  --tag=CXX   --mode=link i686-pc-mingw32-g++
> -mms-bitfields  -module -avoid-version -no-undefined -Wl,--kill-at
> -Wl,  -L/usr/win32/lib -o npvlc.la -rpath //lib vlcshell.lo
> vlcplugin.lo npolibvlc.lo nporuntime.lo npwin.lo
> -L/home/lassauge/VLC/vlc/_win32/lib -lvlc -lvlccore    -lgdi32 
> *** Warning: This system can not link to static lib
> archive /usr/win32/lib/libgpg-error.la. *** I have the capability to
> make that library automatically link in when *** you link to this
> library.  But I can only do this if you have a *** shared version of
> the library, which you do not appear to have. *** But as you try to
> build a module library, libtool will still create *** a static
> module, that should work as long as the dlopening application *** is
> linked with the -dlopen flag to resolve symbols at runtime.
> I'm unable to have the dll build (but it works perfectly for
> axvlc.dll). Do you have any hints ?

Last time I tried it worked, check the buildbot logs and compare to
your setup

BTW linking to libvlccore is an error, npapi (and activex) should only
depend on libvlc, perhaps libvlccore is pulling the edpendancy on
libgpg-error through the libtool archives?

Rafaël Carré

More information about the vlc-devel mailing list