[vlc-devel] Fwd: memmove

Rémi Denis-Courmont remi at remlab.net
Sun Apr 10 12:20:05 CEST 2011

FYI, do not compile (VLC) with gcc >= 4.6 and glibc < 2.13.

You were warned.

----------  Forwarded message  ----------
On 2011-04-10 12:18, Török Edwin wrote:
> Marc Glisse wrote:
>> Hello,
>> in the prototype of memmove (taken from glibc bits/string3.h), you will 
>> notice __restrict in front of the arguments. This is not present in more 
>> recent glibc versions and is a likely cause of your trouble.
> Indeed if I remove __restrict the bug is gone, and if I upgrade to libc6
> 2.13-0exp5, VLC's dec.c seems to be compiled correctly too.
> Should gcc-4.6 depend on glibc >= 2.13?
> Or should gcc-4.6 provide a fixed prototype for memmove via fix-includes?

FWIW here are the upstream glibc commits fixing the use of memmove:

If those patches are backported to Debian's libc-2.11.2, then gcc-4.6
could be made to depend on libc-2.11.2 >= fixed_version.
Should I clone this bug for libc?

Best regards,

More information about the vlc-devel mailing list