[vlc-devel] a pitfall when cross-compiling win32 build on 64bit machine

Rémi Denis-Courmont remi at remlab.net
Wed Dec 14 09:05:39 CET 2011

   Naohiro-san hello,

On Wed, 14 Dec 2011 15:48:54 +0900, Naohiro KORIYAMA <nkoriyama at gmail.com>
> I compile win32 build on OS X Lion.
> First, it seemed fine, but lua scripts didn't run at all.
> I installed lua in /usr/local/bin, and it was built as 64bit
> And, I found the following in the LUAC man page:
> The binary files created by luac are portable only among architectures
> with the same word size and byte order.

Is that so? I thought it was only byte order.

Then it depends what "word size" is? Only long has a different size on
x86-64 than on i386, while char, short, int and long long are same.

> Oops, that's it.
> After I made luac 32bit version, and use it by "LUAC=luac32
> ..../win32/configure.sh ...", lua scripts worked on win32 build.
> I don't know about Linux 64bit environment, on
> http://wiki.videolan.org/Win32Compile, there is no description about
> it.

I am not sure anybody ever tried to run the result.

Unfortunately, there is no lua cross-compiler, so there is no easy way to
fix this.

Rémi Denis-Courmont

More information about the vlc-devel mailing list