[vlc-devel] RTP Streaming

J Decker d3ck0r at gmail.com
Fri Jul 1 19:49:48 CEST 2011

1) sorry this is to developer and not user....

Okay I'm just trying to use RTP to stream some things

http://www.videolan.org/doc/streaming-howto/en/ch04.html  This page
seems to be duplicated over and over and indicates that I can do

vlc -vvv input_stream --sout

(replacing I think 'input_stream' with dshow:// for instance?)

and on the other side vlc rtsp://server.example.org:8080/test.sdp

But, the first line says

stream_out_standard debug: extension -> mux=(null)
stream_out_standard error: no mux specified or found by extension

in the message log....

I used to use this line to launch a stream


but that's coming back with the same error now... and that even has a
'mux=ts' in it.
I saw on another place that RTP is a mux, ...... and shouldn't use
mux=ts on that (I tried adding that to the above commands and it
didn't help with no mux specified....

Sincerely confused,

More information about the vlc-devel mailing list