[vlc-devel] Hi, Problem with VLC VOD with STB

Adalberto Toledo Escalona thebest_94 at hotmail.com
Tue Mar 1 21:44:35 CET 2011

Hi, I'm Trying using vlc 1.0.6 Goldeneye  installed in Ubuntu 10.04 LTS to run a video via Video On Demand to play the stream with a Set Top Box...

I did these steps:

[b]Video On Demand
Basic example

First launch the vlc

% vlc --ttl 12 -vvv --color -I telnet --telnet-password videolan --rtsp-host


      12 is the value of the TTL (Time To Live) of your IP packets (which means that the stream will be able to cross 11 routers).

      telnet launches the telnet interface of the vlc.

      videolan is the password to connect to the telnet interface. is the host address.

      5554 is the port on which you stream. 

Then you connect to the vlc telnet interface and create the vod object

new Test vod enabled
setup Test input my_video.mpg

You can access to the stream with:

% vlc rtsp://server:5554/Test


       server is the address of the streaming server (IP or DNS)[/b]

And it worked fine in the local machine and in another one (Windows 7) via network with vlc, but when I try to play it in the Set Top Box it doesn't work...

The messages that I received from the STB are:

When I run a video from VLC IGMP (Multicast Stream) or from ANEVIA SERVER RTSP (VOD, Unicast Stream) the STB works fine...

But I want to do it from RTSP (VOD, Unicast Stream)

The Set Top Box that I have is amino 130h

[b]What am I doing wrong? Can anyone help me...?[/b] 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20110301/d4f31efd/attachment.html>

More information about the vlc-devel mailing list