[vlc-devel] [PATCH] introduce CLIP() macro to replace use pair of __MAX() and __MIN()

Rafaël Carré funman at videolan.org
Tue Nov 15 17:01:54 CET 2011

Le Tue, 15 Nov 2011 15:15:44 +0800,
Can Wu <wu.canus at gmail.com> a écrit :


This patch looks nice, thanks

However I fear the name 'CLIP' might clash with some header of some library.

We should use __CLIP like the old macros, or use a prefix like VLC_CLIP
(because _ prefixes are illegal according to C standard)

Rafaël Carré

More information about the vlc-devel mailing list