[vlc-devel] [PATCH 2/3] Define the some macros to avoid name clashes on OS/2.
KO Myung-Hun
komh78 at gmail.com
Sat Jan 28 05:22:45 CET 2012
Rafaël Carré wrote:
> Le 11-12-21 06:49, KO Myung-Hun a écrit :
>>
>>
>> Jean-Baptiste Kempf wrote:
>>> On Tue, Dec 20, 2011 at 08:29:46PM +0900, KO Myung-Hun wrote :
>>>> They are
>>>>
>>>> #define BITMAPINFOHEADER VLC_BITMAPINFOHEADER
>>>> #define PBITMAPINFOHEADER VLC_PBITMAPINFOHEADER
>>>> #define LPBITMAPINFOHEADER VLC_LPBITMAPINFOHEADER
>>>> #define BITMAPINFO VLC_BITMAPINFO
>>>> #define LPBITMAPINFO VLC_LPBITMAPINFO
>>>>
>>>> OS/2 has already the types of the same name, but the different member name.
>>>
>>> I am really not at ease with that...
>>>
>>> BITMAPINFOHEADER is quite defined by MicroSoft. Any way to undef the
>>> OS/2 defines?
>>>
>>>
>>
>> Unfortunately, it is also defined by IBM.
>>
>> I'm sorry I don't know how to undef 'typedef'.
>
> What are the differences ?
>
> http://en.wikipedia.org/wiki/BMP_file_format#DIB_header_.28bitmap_information_header.29
> shows a different name for OS/2 but perhaps it's only an alias?
Here are OS/2 definitions,
typedef struct _BITMAPINFOHEADER /* bmp */
{
ULONG cbFix;
USHORT cx;
USHORT cy;
USHORT cPlanes;
USHORT cBitCount;
} BITMAPINFOHEADER;
typedef BITMAPINFOHEADER *PBITMAPINFOHEADER;
/* bitmap data used by GpiSetBitmapBits and others */
typedef struct _BITMAPINFO /* bmi */
{
ULONG cbFix;
USHORT cx;
USHORT cy;
USHORT cPlanes;
USHORT cBitCount;
RGB argbColor[1];
} BITMAPINFO;
typedef BITMAPINFO *PBITMAPINFO;
--
KO Myung-Hun
Using Mozilla SeaMonkey 2.0.14
Under OS/2 Warp 4 for Korean with FixPak #15
On Intel Core2Duo T5500 1.66GHz with 2GB RAM
Korean OS/2 User Community : http://www.ecomstation.co.kr
More information about the vlc-devel
mailing list