[vlc-devel] cannot open hardware acceleration on android 2.3.4

ScottLin scottlin at condel-tech.com
Thu Mar 29 05:24:29 CEST 2012

Thank you for your advice.
I dig into the function CreateComponentsList() and find it fails at line
155 in omxil.c.
the line number may different to yours since I add some debug code.

155:    omx_error = pf_component_enum(psz_name, OMX_MAX_STRINGNAME_SIZE, i);
156:    if(omx_error != OMX_ErrorNone) break;

and the error is OMX_ErrorNoMore.

the index i is 0.
So there is no component which could be used to match any of the format.

I doubt the there might be problem in the dll so i changed the dll from
libiomx.so to libiomx-gingerbread.so.
Still don't work.

BTW, I tried the apk from the post on XDA.
The same result as the one I built.

Any suggestions? Where should I trace?

Best regards,

2012/3/28 Jean-Baptiste Kempf <jb at videolan.org>

> On Wed, Mar 28, 2012 at 04:40:38PM +0800, ScottLin wrote :
> > *Where should I follow and trace to fix the issue?*
> You should add debug information to this files and recompile to
> understand where it fails exactly.
> Best regards,
> --
> Jean-Baptiste Kempf
> http://www.jbkempf.com/ - +33 672 704 734
> Sent from my Electronic Device
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20120329/4e31479f/attachment.html>

More information about the vlc-devel mailing list