[vlc-devel] Segmentation fault

Masaru Nomiya nomiya at galaxy.dti.ne.jp
Sun Apr 21 12:46:32 CEST 2013


In the Message; 

  Subject    : Re: [vlc-devel] Segmentation fault
  Message-ID : <CAMKrNtyukrtZEAQ=2nzwL412XOxJsUtZ06S1JDRkrLzrVkKbMw at mail.gmail.com>
  Date & Time: Sun, 21 Apr 2013 09:26:02 +0300

Kaarlo Räihä <kaarlo.raiha at gmail.com> has written:

>> 2013/4/21 Masaru Nomiya <nomiya at galaxy.dti.ne.jp>

>>     Hello,
>>     I got the very latest git of vlc, then compiled.
>>     But, I got the "Segmentation fault" for this several days.
>>     $ vlc temp/multimedia/KOIBITOYO.mp4
>>     VLC media player 2.1.0-git Rincewind (revision 1.3.0-git-6355-g38499f2)
>>     [0x1f155c8] skins2 interface: skin: subX  author: Martin Poehlmann
>>     Segmentation fault
>>     Any hint?

> Do other GUI modules (e.g. QT4) work better?

No, I get same result.

> If you want more accurate crash report, then use gdb and call bt when crash
> occurs.

I'm not sure, but tried.

$ gdb /usr/local/bin/vlc
GNU gdb (GDB) SUSE (
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
For bug reporting instructions, please see:
Reading symbols from /usr/local/bin/vlc...(no debugging symbols found)...done.
(gdb) r temp/multimedia/ADELE_SOMEONE_LIKE_YOU.mp4 
Starting program: /usr/local/bin/vlc temp/multimedia/ADELE_SOMEONE_LIKE_YOU.mp4
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.1.0-git Rincewind (revision 38499f2)
[New Thread 0x7fffd8fe2700 (LWP 608)]
[New Thread 0x7fffd8ee1700 (LWP 609)]
[New Thread 0x7fffd89b3700 (LWP 610)]
[New Thread 0x7fffd6f53700 (LWP 611)]
[New Thread 0x7fffd6e52700 (LWP 612)]
[0x6c2828] [cli] lua interface: Listening on host "*console".
VLC media player 2.1.0-git Rincewind
Command Line Interface initialized. Type `help' for help.
> [New Thread 0x7fffd694a700 (LWP 613)]
[Thread 0x7fffd8ee1700 (LWP 609) exited]
[New Thread 0x7fffc7fff700 (LWP 614)]
[New Thread 0x7fffc77fe700 (LWP 615)]
[New Thread 0x7fffc6ffd700 (LWP 616)]
[New Thread 0x7fffc67fc700 (LWP 617)]
[New Thread 0x7fffd8ee1700 (LWP 618)]
[New Thread 0x7fffd45c0700 (LWP 619)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd45c0700 (LWP 619)]
0x00007fffda47169c in ?? ()
   from /usr/local/lib64/vlc/plugins/audio_output/libalsa_plugin.so
Missing separate debuginfos, use: zypper install vlc-debuginfo-2.1.0.git-20130421.2.x86_64
(gdb) backtrace 
#0  0x00007fffda47169c in ?? ()
   from /usr/local/lib64/vlc/plugins/audio_output/libalsa_plugin.so
#1  0x00007ffff7950b68 in ?? () from /usr/local/lib64/libvlccore.so.5
#2  0x00007ffff794df15 in ?? () from /usr/local/lib64/libvlccore.so.5
#3  0x00007ffff791a0e5 in ?? () from /usr/local/lib64/libvlccore.so.5
#4  0x00007fffd623835d in ?? ()
   from /usr/local/lib64/vlc/plugins/codec/libfaad_plugin.so
#5  0x00007ffff791a380 in ?? () from /usr/local/lib64/libvlccore.so.5
#6  0x00007ffff791b6e5 in ?? () from /usr/local/lib64/libvlccore.so.5
#7  0x00007ffff791b7f3 in ?? () from /usr/local/lib64/libvlccore.so.5
#8  0x00007ffff6b0cf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007ffff664c10d in clone () from /lib64/libc.so.6

Is this?

Thanks in advance.

┏━━┓彡 Masaru Nomiya             mail-to: nomiya @ galaxy.dti.ne.jp
┗━━┛ "Bill! You married with Computers.
          Not with Me!"
         "No..., with money."

More information about the vlc-devel mailing list