[vlc-devel] [PATCH] contrib: fix compilation of libraries for iOS which deploy cmake

Rafaël Carré funman at videolan.org
Tue Dec 3 00:17:55 CET 2013


Hi,

Le 30/11/2013 20:25, Felix Paul Kühne a écrit :
> ---
>  contrib/bootstrap    | 19 +++++++++++++++++++
>  contrib/src/main.mak |  3 +++
>  2 files changed, 22 insertions(+)
> 
> diff --git a/contrib/bootstrap b/contrib/bootstrap
> index f0bfe91..246e3d6 100755
> --- a/contrib/bootstrap
> +++ b/contrib/bootstrap
> @@ -151,6 +151,24 @@ add_make_enabled()
>  	done
>  }
>  
> +check_ios_sdk()

Looks like it is a duplication of check_macosx_sdk.

I would call it with:

check_osx_sdk "MacOSX"
and
check_osx_sdk "iPhone${PLATFORM}"

> +{
> +   if test -z "$SDKROOT"
> +   then
> +      SDKROOT=`xcode-select -print-path`/Platforms/iPhone${PLATFORM}.platform/Developer/SDKs/iPhone${PLATFORM}${SDK_VERSION}.sdk

And use /Platforms/$1.platform/.....

> +      echo "SDKROOT not specified, assuming $SDKROOT"
> +   else
> +      SDKROOT="$SDKROOT"
> +      fi
> +
> +   if [ ! -d "${SDKROOT}" ]
> +   then
> +      echo "*** ${SDKROOT} does not exist, please install required SDK, or set SDKROOT manually. ***"
> +      exit 1
> +   fi
> +   add_make "IOS_SDK=${SDKROOT}"
> +}
> +
>  check_macosx_sdk()
>  {
>     [ -z "${OSX_VERSION}" ] && echo "OSX_VERSION not specified, assuming 10.7" && OSX_VERSION=10.7
> @@ -206,6 +224,7 @@ case "${OS}" in
>  			check_macosx_sdk
>  			add_make_enabled "HAVE_MACOSX" "HAVE_DARWIN_OS" "HAVE_BSD"
>  		else
> +			check_ios_sdk
>  			add_make_enabled "HAVE_IOS" "HAVE_DARWIN_OS" "HAVE_BSD" "HAVE_NEON" "HAVE_ARMV7A"
>  		fi
>  		;;
> diff --git a/contrib/src/main.mak b/contrib/src/main.mak
> index 4e568ec..9562165 100644
> --- a/contrib/src/main.mak
> +++ b/contrib/src/main.mak
> @@ -397,6 +397,9 @@ ifdef HAVE_DARWIN_OS
>  	echo "set(CMAKE_LD_FLAGS $(LDFLAGS))" >> $@
>  ifdef HAVE_IOS
>  	echo "set(CMAKE_AR ar CACHE FILEPATH "Archiver")" >> $@
> +	echo "set(CMAKE_OSX_SYSROOT $(IOS_SDK))" >> $@
> +else
> +	echo "set(CMAKE_OSX_SYSROOT $(MACOSX_SDK))" >> $@

Can you find a common name? DARWIN_SDK ?

>  endif
>  endif
>  ifdef HAVE_CROSS_COMPILE
> 




More information about the vlc-devel mailing list