[vlc-devel] issue with gettext version when configuring gpg-error

Gilles Sabourin gilles.sabourin at free.fr
Tue May 12 09:58:10 CEST 2015

Hello dear vlc team,

Generation stops when configuring gpg-error. Gettext version 0.19.3 seems to be  
mandatory but my openSUSE 13.2 is only offering gettext 0.19.2

Would it be possible to use gettext 0.19.3 from contribs and build gpg-error 
as a dependency of this one and not the one from the environment? 

Best Regards,
Gilles Sabourin

(cd libgpg-error-1.18 && patch -fp1) < ../../contrib/src/gpg-error/missing-
patching file tests/t-lock.c
Hunk #1 succeeded at 24 with fuzz 2.
(cd libgpg-error-1.18 && patch -fp1) < ../../contrib/src/gpg-error/no-
patching file Makefile.am
patching file src/Makefile.am
mv libgpg-error-1.18 libgpg-error && touch libgpg-error
cp libgpg-error/src/syscfg/lock-obj-pub.arm-unknown-linux-androideabi.h 
mkdir -p -- /usr/src/packages/BUILD/vlc-beta-3.0.0/contrib/i586-suse-
linux/share/aclocal && cd libgpg-error && autoreconf -fiv -
autoreconf: Entering directory `.'
autoreconf: running: autopoint --force
autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac
               file requires the infrastructure from gettext-0.19.3 but this 
               is older. Please upgrade to gettext-0.19.3 or newer.
autopoint: *** Stop.

More information about the vlc-devel mailing list