[vlc-devel] [PATCH 2/9] mkv: rename ChangeSegment() to KeepTrackSelection()

Steve Lhomme robux4 at videolabs.io
Thu Mar 17 16:53:01 CET 2016


---
 modules/demux/mkv/virtual_segment.cpp | 5 +++--
 modules/demux/mkv/virtual_segment.hpp | 2 +-
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/modules/demux/mkv/virtual_segment.cpp b/modules/demux/mkv/virtual_segment.cpp
index f9e8f1e..34e82b7 100644
--- a/modules/demux/mkv/virtual_segment.cpp
+++ b/modules/demux/mkv/virtual_segment.cpp
@@ -523,7 +523,7 @@ void virtual_segment_c::Seek( demux_t & demuxer, mtime_t i_mk_date,
 
         if( &p_current_vchapter->segment != &p_vchapter->segment )
         {
-            ChangeSegment( p_current_vchapter->segment, p_vchapter->segment );
+            KeepTrackSelection( p_current_vchapter->segment, p_vchapter->segment );
             p_current_vchapter->segment.UnSelect();
             p_vchapter->segment.Select( i_mk_date );
         }
@@ -660,10 +660,11 @@ void virtual_chapter_c::print()
 }
 #endif
 
-void virtual_segment_c::ChangeSegment( matroska_segment_c & old, matroska_segment_c & next )
+void virtual_segment_c::KeepTrackSelection( matroska_segment_c & old, matroska_segment_c & next )
 {
     size_t i, j;
     char *sub_lang = NULL, *aud_lang = NULL;
+    /* get the current ES language selection */
     for( i = 0; i < old.tracks.size(); i++)
     {
         mkv_track_t *p_tk = old.tracks[i];
diff --git a/modules/demux/mkv/virtual_segment.hpp b/modules/demux/mkv/virtual_segment.hpp
index 04be7c8..2c83165 100644
--- a/modules/demux/mkv/virtual_segment.hpp
+++ b/modules/demux/mkv/virtual_segment.hpp
@@ -162,7 +162,7 @@ public:
     void Seek( demux_t & demuxer, mtime_t i_mk_date,
                virtual_chapter_c *p_vchapter, int64_t i_global_position );
 private:
-    void ChangeSegment( matroska_segment_c & p_old, matroska_segment_c & p_new );
+    void KeepTrackSelection( matroska_segment_c & old, matroska_segment_c & next );
 };
 
 #endif
-- 
2.7.1



More information about the vlc-devel mailing list