[vlc-devel] [PATCH 0/3] qt: /modules/gui/qt/util/input_slider.{cpp, hpp}
Filip Roséen
filip at videolabs.io
Tue Mar 22 19:26:03 CET 2016
When working on the matroska module I noticed that the tooltip when hovering
the SeekSlider with your mouse in the GUI would tell you that it would seek to
one location, and then end up somewhere else (because the tooltip and the
underlying code was not doing the same thing when calculating where to seek).
These patches fixes that, and cleans up some of the code along the way.
Filip Roséen (3):
qt: replaced macros with proper constants
qt: replaced magic constants with QtAbstractSlider::{maximum,minimum}
qt: make seek tooltip + actual seek less surprising
modules/gui/qt/util/input_slider.cpp | 51 +++++++++++++++++++++++++-----------
modules/gui/qt/util/input_slider.hpp | 3 +++
2 files changed, 38 insertions(+), 16 deletions(-)
--
2.7.4
More information about the vlc-devel
mailing list