[vlc-devel] [PATCH 0/5] variables: add VLC_VAR_LIST
Thomas Guillem
thomas at gllm.fr
Thu Nov 3 10:16:46 CET 2016
This patch-set adds the possibility to store a list of
int/bool/float/string/coords inside a VLC variable. The first 3 patches rename
old List functions that are only used for Choice variables ("video-es" for
example) in order to avoid confusion with the new VLC_VAR_LIST.
This new list variable could be used to get/set atomically (and maybe
increment/decrement in a future patch) a set of values. The main purpose is to
store the 3 yaw/pitch/roll variables, that will be needed for 360 patches,
inside one variable in the vout.
Thomas Guillem (5):
variables: rename var_FreeList to var_FreeChoiceLists
variables: rename var_{Add/Del}ListCallback to
var_{Add/Del}ChoiceCallback
variables: move documentation to headers
variables: add VLC_VAR_LIST
variables: test VLC_VAR_LIST
include/vlc_common.h | 12 +-
include/vlc_variables.h | 227 ++++++++++++++++++-
lib/audio.c | 2 +-
lib/media_player.c | 14 +-
lib/video.c | 6 +-
modules/control/gestures.c | 4 +-
modules/control/hotkeys.c | 36 +--
modules/control/oldrc.c | 6 +-
modules/gui/macosx/VLCMainMenu.m | 2 +-
modules/gui/qt/components/controller_widget.cpp | 2 +-
modules/gui/qt/components/extended_panels.cpp | 4 +-
modules/gui/qt/input_manager.cpp | 2 +-
modules/gui/qt/menus.cpp | 2 +-
modules/lua/libs/variables.c | 2 +-
src/input/input.c | 2 +-
src/libvlc.h | 13 ++
src/libvlccore.sym | 5 +-
src/misc/variables.c | 285 +++++++++---------------
test/src/misc/variables.c | 87 +++++++-
19 files changed, 476 insertions(+), 237 deletions(-)
--
2.9.3
More information about the vlc-devel
mailing list