[vlc-devel] [PATCH] input/mrl_helpers: fix warning related to iteration variable
filip at atch.se
Mon Feb 20 18:14:04 CET 2017
On 2017-02-20 18:32, Rémi Denis-Courmont wrote:
> Le maanantaina 20. helmikuuta 2017, 14.53.50 EET Filip Roséen a écrit :
> > Following the changes in 7ecd927 the changed line caused a warning
> > related to signed vs unsigned integer comparision; this simply silence
> > that warning by using the now relevant type.
> Well yes but I left it because this code should use init/clear instead of new/
> destroy (and I have not yet fixed that occurrence).
Understood, I just wanted to get rid of the current warnings as they
hurt my eyes. Unless you plan on fixing the migration from
`vlc_array_new` to `vlc_array_init` and `vlc_array_clear` tonight I'd
be happy to do it.
While we are speaking about the matter, do you think it would make
sense to introduce a *`vlc_array_t`-initializer* that could be used as
the below (not sure about the name though).
vlc_array_t foo = VLC_ARRAY_INIT;
instead of having:
vlc_array_init( &foo );
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the vlc-devel