[vlc-devel] [PATCH 1/5] core: move input.c to input_internal.c

Jean-Baptiste Kempf jb at videolan.org
Tue Jul 10 18:46:59 CEST 2018


On Tue, 10 Jul 2018, at 18:24, Rémi Denis-Courmont wrote:
> Le tiistaina 10. heinäkuuta 2018, 16.43.05 EEST Thomas Guillem a écrit :
> > Leave input.c for the future "input manager", that will be called
> > vlc_input_t.
> Jokes aside, I don't think the input thread parent can be described as an 
> input, really. In LibVLC side, the corresponding object type is called media 
> player, not input - and it manages both inputs and outputs.
> So while I agree that manager is not a very inspired word for a name, I would 
> argue that input is even less inspired. The best I can come up with is 
> vlc_player_t, vlc_media_player_t or vlc_media_handler_t but there are probably 
> better options.

I disliked manager as a name, because it is too generic.
And yet, it is not a full player, but well...

Jean-Baptiste Kempf -  President
+33 672 704 734

More information about the vlc-devel mailing list