[vlc-devel] [V3 2/3] input: add input_SetTime and input_SetPosition
quinkblack at foxmail.com
Wed Jun 27 05:47:14 CEST 2018
On 2018年06月26日 16:50, Thomas Guillem wrote:
> On Tue, Jun 26, 2018, at 10:20, Rémi Denis-Courmont wrote:
>> Le lundi 25 juin 2018, 11:03:49 EEST Zhao Zhili a écrit :
>>> include/vlc_input.h | 4 ++++
>>> src/input/input.c | 59
>>> ++++++++++++++++++++++++++-------------------- src/input/input_internal.h |
>>> 9 ++++++-
>>> src/input/var.c | 6 +++--
>>> src/libvlccore.sym | 2 ++
>>> 5 files changed, 52 insertions(+), 28 deletions(-)
>> *Again*, please don't clobber the global namespace more than already.
> I said to Zhao it was OK since we already have some input_ functions and I don't want to have vlc_input_ and input_ as prefix for the same input API.
> So, we should we rename all input_ to vlc_input_ ?
I like following the current naming style and do the rename in another
patch group. It doesn't add much burden to the following task. But if
the rename doesn't have a schedule in the near future, I'm fine to add
the vlc_ prefix.
>> Rémi Denis-Courmont
>> vlc-devel mailing list
>> To unsubscribe or modify your subscription options:
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
More information about the vlc-devel