[vlc-devel] [PATCH] picture: refactor to use common code in cloning
mwhitworth at gmail.com
Sat Mar 3 17:00:16 CET 2018
On Sat, Mar 3, 2018 at 3:01 PM, Rémi Denis-Courmont <remi at remlab.net> wrote:
>> -picture_t *picture_Clone(picture_t *picture)
>> +picture_t *picture_CloneFromResourceTemplate(picture_t *picture,
> That's a rather poor choice of name IMO, given that there is no
> picture_resource_t parameter.
Yes, also the picture_Clone prefix will be confusing, since it doesn't
include the context copy. Does anyone have a better suggestion for
this common internal function's name?
> Simpler to just return NULL on the failure case and deindent. Ditto below.
More information about the vlc-devel