[vlc-devel] [PATCH] [GSoC] Problems with compiling VLC on Ubuntu 16.04 and other questions.

Kushal K S V S kkushal32 at gmail.com
Wed Mar 7 04:33:32 CET 2018

Hi all,
I am Kushal K S V S. I was going through the GSoC 2018 ideas list and found
the project 'VLC cryptographic updates' interesting.
I've worked with 'The FreeType Org' last year under GSoC 2017 program to
make a test suite for text rendering.
I believe I have the necessary skills and the experience required to
execute this project. I want to draft a proposal on this idea.
I could find only limited info about this. I wanted to know where I could
get the resources to guide me to start working.
(Any similar implementations available ? etc)

I was going through the VLC documentation to compile using the steps on the
page ( https://wiki.videolan.org/UnixCompile ).

When I run the script 'bootstrap', I see the following message.

    NOTE: autopoint (GNU gettext-tools) appears to be missing or
    Please install or update GNU gettext tools.
    Otherwise, you will not be able to build a source tarball.

I cross-check the installed version and the latest version of 'autopoint'
in the ubuntu packages website. I have the latest one installed.
Then why is this warning still there ? I think '--version' option should be
there instead. Here is the patch I tested on Ubuntu 16.04 which does the

>From b384dea21ac98bb7775612ad01f8044668433491 Mon Sep 17 00:00:00 2001
From: Kushal K S V S <kkushal32 at gmail.com>
Date: Wed, 7 Mar 2018 07:45:26 +0530
Subject: [PATCH] Checking autopoint version correctly

 bootstrap | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/bootstrap b/bootstrap
index 995fee2..e01f3c3 100755
--- a/bootstrap
+++ b/bootstrap
@@ -39,7 +39,7 @@ fi
 # Check for autopoint (GNU gettext)
 test "$AUTOPOINT" || AUTOPOINT=autopoint
-if ! "$AUTOPOINT" --dry-run --force >/dev/null 2>&1; then
+if ! "$AUTOPOINT" --version >/dev/null 2>&1; then
  cat << EOF
 NOTE: autopoint (GNU gettext-tools) appears to be missing or out-of-date.

Also in the section 'Get the third-party libraries', in 'The preferred
method',  when I do

     $sudo apt-get build-dep vlc

this is the output.

     Reading package lists... Done
     E: You must put some 'source' URIs in your sources.list

My ubuntu is up-to date. What to do now ?
I think source should be specified in the documentation.

So, now I am compiling it using the second alternative. ( The contrib
method )
It asked for protobuf-compiler. When I installed it, it is saying

     Unrecognized syntax identifier "proto3".  This parser only recognizes

but the version installed is 2.6.1-1.3
Why is this happening ? What's the solution ?

I was also looking into the project 'libVLC AirPlay support'. I work on a
MacBook and have a couple of iOS devices.
Don't we need Apple TV/any AirPlay-enabled hardware to receive the signal ?
Or can we make any computer do this ?
AFAIK there are services like AirServer that do this. What's the best
possible solution for this ? (which isn't costly :P )

Thank You.

P.S: I love VLC and it would be an honour work on projects that are so

P.P.S: I'm sorry if this mail is received twice. Didn't subscribe to the
list the first time. (Couldn't find it in archives)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20180307/94337427/attachment.html>

More information about the vlc-devel mailing list