[vlc-devel] [PATCH 0/5] cpp: renaming all *sys_t because of ODR
Thomas Guillem
thomas at gllm.fr
Wed Mar 7 17:31:54 CET 2018
Hi,
After loosing some times in a memory corruption on vlc-ios because VLC violates
the One Definition Rule, I started to rename all *sys_t in all cpp modules.
(spatialaudio filter_sys_t was used from the blend module)
If you agree with my naming convention and everything, I'll continue and fix
all others cpp modules.
The sys_t renaming will need to be backported to 3.0.
Then, in 4.0, we can remove all *sys_t typedef and replace it with void*. Do
you agree ?
Regards,
Thomas Guillem (5):
blend: rename filter_sys_t to filter_blend
spatialaudio: rename filter_sys_t to filter_spatialaudio
mkv: rename demux_sys_t to demux_mkv
sapi: rename filter_sys_t to filter_sapi
dshow: rename access_sys_t to access_dshow
modules/access/dshow/access.h | 11 +++---
modules/access/dshow/crossbar.cpp | 4 +--
modules/access/dshow/dshow.cpp | 40 +++++++++++-----------
modules/access/dshow/filter.cpp | 4 +--
modules/access/dshow/filter.h | 6 ++--
.../audio_filter/channel_mixer/spatialaudio.cpp | 39 +++++++++++----------
modules/demux/mkv/chapter_command.hpp | 18 +++++-----
modules/demux/mkv/demux.cpp | 26 +++++++-------
modules/demux/mkv/demux.hpp | 6 ++--
modules/demux/mkv/matroska_segment.cpp | 8 ++---
modules/demux/mkv/matroska_segment.hpp | 4 +--
modules/demux/mkv/mkv.cpp | 18 +++++-----
modules/demux/mkv/mkv.hpp | 2 ++
modules/demux/mkv/util.cpp | 2 +-
modules/demux/mkv/virtual_segment.cpp | 6 ++--
modules/text_renderer/sapi.cpp | 11 +++---
modules/video_filter/blend.cpp | 13 +++----
17 files changed, 111 insertions(+), 107 deletions(-)
--
2.11.0
More information about the vlc-devel
mailing list